FAQ – Frequently Asked Questions

Which requirements have to be
met by my smartphone?

  • The Battery-Guard is compatible to IPhone 4S or higher and Android Smartphones with Android 4.3 or higher. It is important, that Android 4.3 is the basic operating system on the phone and not an update version. Older smartphones do not support the BLE (Bluetooth Low Energy) standard.

How much is the Battery-Guard’s operating range?

  • Depending on the mounting place, the Battery-Guard’s operating range is about 5m.

Why isn’t there a fuse with the Battery-Guard?

  • A fuse is obstructed in the Battery-Guard in order to avoid damages to the vehicle and the sensor. This fuse is activating itself automatically after connecting and disconnecting the sensor to the battery.

Can there be damages to the battery of the Battery-Guard if there is a reverse connection?

  • No, there won’t be any damages.

In which languages is the app available?

  • The app will be installed in German in German-speaking regions automatically, while in other countries it will be installed in English. Further languages are in preparation.

I am asked to enter a PIN – what to do?

  • No PIN is needed. Please, only start the app and it will connect to the transmitter automatically. A connection of the smartphone with the transmitter via pairing is not necessary.

I do not get a connection to the Battery-Guard – what can be the error?

  • Is your smartphone suitable to the App? (see FAQ no. 1)
  • If the Battery-Guard is not mounted to the battery directly, please check if there is any voltage to the vehicle parts.
  • Is the Battery-Guard mounted correctly? Red cable + terminal / Black cable – terminal

The connection is breaking down again and again.

  • Please check the mounting place of the Battery-Guard. Perhaps the place is shielded so much, so the Bluetooth signal is to weak.